Out-of-bounds Read Affecting libraw package, versions <0.18.8-1ubuntu0.4+esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.44% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-LIBRAW-9828208
  • published7 May 2025
  • disclosed21 Apr 2025

Introduced: 21 Apr 2025

CVE-2025-43962  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 libraw to version 0.18.8-1ubuntu0.4+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libraw package and not the libraw package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

In LibRaw before 0.21.4, phase_one_correct in decoders/load_mfbacks.cpp has out-of-bounds reads for tag 0x412 processing, related to large w0 or w1 values or the frac and mult calculations.

CVSS Base Scores

version 3.1