Resource Exhaustion Affecting librsvg package, versions *


low

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Availability High

    Threat Intelligence

    EPSS 0.55% (77th percentile)
Expand this section
NVD
6.5 medium
Expand this section
SUSE
6.5 medium
Expand this section
Red Hat
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-UBUNTU1804-LIBRSVG-589927
  • published 2 Feb 2020
  • disclosed 2 Feb 2020

How to fix?

There is no fixed version for Ubuntu:18.04 librsvg.

NVD Description

Note: Versions mentioned in the description apply only to the upstream librsvg package and not the librsvg package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

In xml.rs in GNOME librsvg before 2.46.2, a crafted SVG file with nested patterns can cause denial of service when passed to the library for processing. The attacker constructs pattern elements so that the number of final rendered objects grows exponentially.