Use After Free Affecting libsass package, versions <3.4.8-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.04% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-LIBSASS-471900
  • published3 Dec 2018
  • disclosed3 Dec 2018

Introduced: 3 Dec 2018

CVE-2018-19827  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 libsass to version 3.4.8-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsass package and not the libsass package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

In LibSass 3.5.5, a use-after-free vulnerability exists in the SharedPtr class in SharedPtr.cpp (or SharedPtr.hpp) that may cause a denial of service (application crash) or possibly have unspecified other impact.