Resource Exhaustion Affecting libsass package, versions *


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.8% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-LIBSASS-471914
  • published4 Dec 2018
  • disclosed4 Dec 2018

Introduced: 4 Dec 2018

CVE-2018-19837  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:18.04 libsass.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsass package and not the libsass package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

In LibSass prior to 3.5.5, Sass::Eval::operator()(Sass::Binary_Expression*) inside eval.cpp allows attackers to cause a denial-of-service resulting from stack consumption via a crafted sass file, because of certain incorrect parsing of '%' as a modulo operator in parser.cpp.