Use After Free Affecting libsass package, versions <3.4.8-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.84% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-LIBSASS-471915
  • published26 May 2018
  • disclosed26 May 2018

Introduced: 26 May 2018

CVE-2018-11499  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 libsass to version 3.4.8-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsass package and not the libsass package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

A use-after-free vulnerability exists in handle_error() in sass_context.cpp in LibSass 3.4.x and 3.5.x through 3.5.4 that could be leveraged to cause a denial of service (application crash) or possibly unspecified other impact.