Out-of-bounds Read Affecting libsdl2 package, versions <2.0.8+dfsg1-1ubuntu1.18.04.4+esm1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.68% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-LIBSDL2-1144110
  • published3 Feb 2021
  • disclosed19 Jan 2021

Introduced: 19 Jan 2021

CVE-2020-14410  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 libsdl2 to version 2.0.8+dfsg1-1ubuntu1.18.04.4+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsdl2 package and not the libsdl2 package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

SDL (Simple DirectMedia Layer) through 2.0.12 has a heap-based buffer over-read in Blit_3or4_to_3or4__inversed_rgb in video/SDL_blit_N.c via a crafted .BMP file.

CVSS Base Scores

version 3.1