Out-of-bounds Write Affecting libsdl2 package, versions <2.0.8+dfsg1-1ubuntu1.18.04.4+esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.32% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-LIBSDL2-1144148
  • published3 Feb 2021
  • disclosed19 Jan 2021

Introduced: 19 Jan 2021

CVE-2020-14409  (opens in a new tab)
CWE-787  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 libsdl2 to version 2.0.8+dfsg1-1ubuntu1.18.04.4+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsdl2 package and not the libsdl2 package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

SDL (Simple DirectMedia Layer) through 2.0.12 has an Integer Overflow (and resultant SDL_memcpy heap corruption) in SDL_BlitCopy in video/SDL_blit_copy.c via a crafted .BMP file.

CVSS Base Scores

version 3.1