Use After Free Affecting libsepol package, versions <2.7-1ubuntu0.1


Severity

Recommended
0.0
low
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.46% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-LIBSEPOL-1315899
  • published3 Jul 2021
  • disclosed1 Jul 2021

Introduced: 1 Jul 2021

CVE-2021-36085  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 libsepol to version 2.7-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsepol package and not the libsepol package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

The CIL compiler in SELinux 3.2 has a use-after-free in __cil_verify_classperms (called from __verify_map_perm_classperms and hashtab_map).

CVSS Base Scores

version 3.1