Cross-site Scripting (XSS) Affecting mathjax package, versions *


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.45% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-MATHJAX-449570
  • published23 Jul 2018
  • disclosed23 Jul 2018

Introduced: 23 Jul 2018

CVE-2018-1999024  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:18.04 mathjax.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mathjax package and not the mathjax package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

MathJax version prior to version 2.7.4 contains a Cross Site Scripting (XSS) vulnerability in the \unicode{} macro that can result in Potentially untrusted Javascript running within a web browser. This attack appear to be exploitable via The victim must view a page where untrusted content is processed using Mathjax. This vulnerability appears to have been fixed in 2.7.4 and later.