CVE-2018-12291 Affecting matrix-synapse package, versions <0.24.0+dfsg-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.79% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-MATRIXSYNAPSE-1193730
  • published13 May 2023
  • disclosed13 Jun 2018

Introduced: 13 Jun 2018

CVE-2018-12291  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 matrix-synapse to version 0.24.0+dfsg-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream matrix-synapse package and not the matrix-synapse package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

The on_get_missing_events function in handlers/federation.py in Matrix Synapse before 0.31.1 has a security bug in the get_missing_events federation API where event visibility rules were not applied correctly.