Improper Verification of Cryptographic Signature Affecting matrix-synapse package, versions <0.24.0+dfsg-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.54% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-MATRIXSYNAPSE-538425
  • published25 Sept 2018
  • disclosed18 Sept 2018

Introduced: 18 Sep 2018

CVE-2018-16515  (opens in a new tab)
CWE-347  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 matrix-synapse to version 0.24.0+dfsg-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream matrix-synapse package and not the matrix-synapse package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Matrix Synapse before 0.33.3.1 allows remote attackers to spoof events and possibly have unspecified other impacts by leveraging improper transaction and event signature validation.