Deserialization of Untrusted Data Affecting mcollective package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.18% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-MCOLLECTIVE-418210
  • published30 Jun 2017
  • disclosed30 Jun 2017

Introduced: 30 Jun 2017

CVE-2017-2292  (opens in a new tab)
CWE-502  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:18.04 mcollective.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mcollective package and not the mcollective package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Versions of MCollective prior to 2.10.4 deserialized YAML from agents without calling safe_load, allowing the potential for arbitrary code execution on the server. The fix for this is to call YAML.safe_load on input. This has been tested in all Puppet-supplied MCollective plugins, but there is a chance that third-party plugins could rely on this insecure behavior.