Cross-site Scripting (XSS) Affecting moin package, versions <1.9.9-1ubuntu1.2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.75% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-MOIN-1038529
  • published10 Nov 2020
  • disclosed11 Nov 2020

Introduced: 10 Nov 2020

CVE-2020-15275  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 moin to version 1.9.9-1ubuntu1.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream moin package and not the moin package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

MoinMoin is a wiki engine. In MoinMoin before version 1.9.11, an attacker with write permissions can upload an SVG file that contains malicious javascript. This javascript will be executed in a user's browser when the user is viewing that SVG file on the wiki. Users are strongly advised to upgrade to a patched version. MoinMoin Wiki 1.9.11 has the necessary fixes and also contains other important fixes.

CVSS Base Scores

version 3.1