Out-of-bounds Read Affecting monit package, versions <1:5.25.1-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.88% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-MONIT-345869
  • published22 Apr 2019
  • disclosed22 Apr 2019

Introduced: 22 Apr 2019

CVE-2019-11455  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 monit to version 1:5.25.1-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream monit package and not the monit package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

A buffer over-read in Util_urlDecode in util.c in Tildeslash Monit before 5.25.3 allows a remote authenticated attacker to retrieve the contents of adjacent memory via manipulation of GET or POST parameters. The attacker can also cause a denial of service (application outage).

CVSS Base Scores

version 3.1