Link Following Affecting nano package, versions <2.9.3-2ubuntu0.1~esm1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.34% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-NANO-7246154
  • published9 Oct 2024
  • disclosed12 Jun 2024

Introduced: 12 Jun 2024

CVE-2024-5742  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 nano to version 2.9.3-2ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nano package and not the nano package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

A vulnerability was found in GNU Nano that allows a possible privilege escalation through an insecure temporary file. If Nano is killed while editing, a file it saves to an emergency file with the permissions of the running user provides a window of opportunity for attackers to escalate privileges through a malicious symlink.

CVSS Base Scores

version 3.1