OS Command Injection Affecting neovim package, versions <0.2.2-3ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
18.96% (98th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-NEOVIM-349374
  • published5 Jun 2019
  • disclosed5 Jun 2019

Introduced: 5 Jun 2019

CVE-2019-12735  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 neovim to version 0.2.2-3ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream neovim package and not the neovim package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

getchar.c in Vim before 8.1.1365 and Neovim before 0.3.6 allows remote attackers to execute arbitrary OS commands via the :source! command in a modeline, as demonstrated by execute in Vim, and assert_fails or nvim_input in Neovim.

References

CVSS Base Scores

version 3.1