Improper Input Validation Affecting netqmail package, versions <1.06-6.2~deb10u1build0.18.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.81% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-NETQMAIL-1014488
  • published30 Sept 2020
  • disclosed26 May 2020

Introduced: 26 May 2020

CVE-2020-3811  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 netqmail to version 1.06-6.2~deb10u1build0.18.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream netqmail package and not the netqmail package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

qmail-verify as used in netqmail 1.06 is prone to a mail-address verification bypass vulnerability.

CVSS Base Scores

version 3.1