Directory Traversal Affecting nltk package, versions <3.2.5-1ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
5.67% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-NLTK-459934
  • published20 Aug 2019
  • disclosed22 Aug 2019

Introduced: 20 Aug 2019

CVE-2019-14751  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 nltk to version 3.2.5-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nltk package and not the nltk package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

NLTK Downloader before 3.4.5 is vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in an NLTK package (ZIP archive) that is mishandled during extraction.