Out-of-bounds Read Affecting node-bl package, versions <1.1.2-1ubuntu1.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.1% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-NODEBL-1128437
  • published1 Nov 2020
  • disclosed30 Aug 2020

Introduced: 30 Aug 2020

CVE-2020-8244  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 node-bl to version 1.1.2-1ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-bl package and not the node-bl package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

A buffer over-read vulnerability exists in bl <4.0.3, <3.0.1, <2.2.1, and <1.2.3 which could allow an attacker to supply user input (even typed) that if it ends up in consume() argument and can become negative, the BufferList state can be corrupted, tricking it into exposing uninitialized memory via regular .slice() calls.

CVSS Base Scores

version 3.1