Open Redirect Affecting node-url-parse package, versions <1.2.0-1ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.81% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-NODEURLPARSE-1179520
  • published21 Mar 2023
  • disclosed12 Aug 2018

Introduced: 12 Aug 2018

CVE-2018-3774  (opens in a new tab)
CWE-601  (opens in a new tab)
CWE-918  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 node-url-parse to version 1.2.0-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-url-parse package and not the node-url-parse package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Incorrect parsing in url-parse <1.4.3 returns wrong hostname which leads to multiple vulnerabilities such as SSRF, Open Redirect, Bypass Authentication Protocol.