Improper Input Validation Affecting nvidia-graphics-drivers-460 package, versions <460.32.03-0ubuntu0.18.04.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.36% (28th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-NVIDIAGRAPHICSDRIVERS460-1059065
  • published8 Jan 2021
  • disclosed8 Jan 2021

Introduced: 8 Jan 2021

CVE-2021-1053  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 nvidia-graphics-drivers-460 to version 460.32.03-0ubuntu0.18.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nvidia-graphics-drivers-460 package and not the nvidia-graphics-drivers-460 package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

NVIDIA GPU Display Driver for Windows and Linux, all versions, contains a vulnerability in the kernel mode layer (nvlddmkm.sys) handler for DxgkDdiEscape or IOCTL in which improper validation of a user pointer may lead to denial of service.

CVSS Base Scores

version 3.1