Integer Overflow or Wraparound Affecting ocaml package, versions <4.05.0-10ubuntu1+esm1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.17% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-OCAML-310203
  • published6 Apr 2018
  • disclosed6 Apr 2018

Introduced: 6 Apr 2018

CVE-2018-9838  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 ocaml to version 4.05.0-10ubuntu1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ocaml package and not the ocaml package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

The caml_ba_deserialize function in byterun/bigarray.c in the standard library in OCaml 4.06.0 has an integer overflow which, in situations where marshalled data is accepted from an untrusted source, allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via a crafted object.