Out-of-bounds Write Affecting opencv package, versions <3.2.0+dfsg-4ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.52% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-OPENCV-293907
  • published8 Jan 2018
  • disclosed8 Jan 2018

Introduced: 8 Jan 2018

CVE-2018-5268  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 opencv to version 3.2.0+dfsg-4ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opencv package and not the opencv package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

In OpenCV 3.3.1, a heap-based buffer overflow happens in cv::Jpeg2KDecoder::readComponent8u in modules/imgcodecs/src/grfmt_jpeg2000.cpp when parsing a crafted image file.

CVSS Base Scores

version 3.1