Reachable Assertion Affecting opencv package, versions <3.2.0+dfsg-4ubuntu0.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.38% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-OPENCV-293935
  • published8 Jan 2018
  • disclosed8 Jan 2018

Introduced: 8 Jan 2018

CVE-2018-5269  (opens in a new tab)
CWE-617  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 opencv to version 3.2.0+dfsg-4ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opencv package and not the opencv package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

In OpenCV 3.3.1, an assertion failure happens in cv::RBaseStream::setPos in modules/imgcodecs/src/bitstrm.cpp because of an incorrect integer cast.

CVSS Base Scores

version 3.1