CVE-2017-12600 Affecting opencv package, versions <3.2.0+dfsg-4ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.24% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-OPENCV-294002
  • published7 Aug 2017
  • disclosed7 Aug 2017

Introduced: 7 Aug 2017

CVE-2017-12600  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 opencv to version 3.2.0+dfsg-4ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opencv package and not the opencv package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

OpenCV (Open Source Computer Vision Library) through 3.3 has a denial of service (CPU consumption) issue, as demonstrated by the 11-opencv-dos-cpu-exhaust test case.