Out-of-bounds Read Affecting opencv package, versions <3.2.0+dfsg-4ubuntu0.1+esm4


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.68% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-OPENCV-467285
  • published19 Sept 2019
  • disclosed11 Sept 2019

Introduced: 11 Sep 2019

CVE-2019-16249  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 opencv to version 3.2.0+dfsg-4ubuntu0.1+esm4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opencv package and not the opencv package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

OpenCV 4.1.1 has an out-of-bounds read in hal_baseline::v_load in core/hal/intrin_sse.hpp when called from computeSSDMeanNorm in modules/video/src/dis_flow.cpp.

CVSS Base Scores

version 3.1