Out-of-bounds Read Affecting opencv package, versions <3.2.0+dfsg-4ubuntu0.1+esm4


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.76% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-OPENCV-541258
  • published8 Dec 2019
  • disclosed6 Dec 2019

Introduced: 6 Dec 2019

CVE-2019-19624  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 opencv to version 3.2.0+dfsg-4ubuntu0.1+esm4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opencv package and not the opencv package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

An out-of-bounds read was discovered in OpenCV before 4.1.1. Specifically, variable coarsest_scale is assumed to be greater than or equal to finest_scale within the calc()/ocl_calc() functions in dis_flow.cpp. However, this is not true when dealing with small images, leading to an out-of-bounds read of the heap-allocated arrays Ux and Uy.

CVSS Base Scores

version 3.1