Out-of-bounds Write Affecting opendmarc package, versions <1.3.2-3ubuntu0.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.68% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-OPENDMARC-1146737
  • published11 Sept 2023
  • disclosed27 Jul 2020

Introduced: 27 Jul 2020

CVE-2020-12460  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 opendmarc to version 1.3.2-3ubuntu0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opendmarc package and not the opendmarc package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

OpenDMARC through 1.3.2 and 1.4.x through 1.4.0-Beta1 has improper null termination in the function opendmarc_xml_parse that can result in a one-byte heap overflow in opendmarc_xml when parsing a specially crafted DMARC aggregate report. This can cause remote memory corruption when a '\0' byte overwrites the heap metadata of the next chunk and its PREV_INUSE flag.

CVSS Base Scores

version 3.1