Information Exposure Affecting openwsman package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
14.74% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-OPENWSMAN-452111
  • published24 Jul 2019
  • disclosed14 Mar 2019

Introduced: 14 Mar 2019

CVE-2019-3816  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:18.04 openwsman.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openwsman package and not the openwsman package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Openwsman, versions up to and including 2.6.9, are vulnerable to arbitrary file disclosure because the working directory of openwsmand daemon was set to root directory. A remote, unauthenticated attacker can exploit this vulnerability by sending a specially crafted HTTP request to openwsman server.

CVSS Base Scores

version 3.1