Out-of-Bounds Affecting pango1.0 package, versions <1.40.14-1ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
11.36% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-PANGO10-294587
  • published22 Aug 2018
  • disclosed24 Aug 2018

Introduced: 22 Aug 2018

CVE-2018-15120  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 pango1.0 to version 1.40.14-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pango1.0 package and not the pango1.0 package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

libpango in Pango 1.40.8 through 1.42.3, as used in hexchat and other products, allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via crafted text with invalid Unicode sequences.

CVSS Base Scores

version 3.1