Incorrect Permission Assignment for Critical Resource Affecting paramiko package, versions <2.0.0-1ubuntu1.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.41% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-PARAMIKO-275386
  • published8 Oct 2018
  • disclosed8 Oct 2018

Introduced: 8 Oct 2018

CVE-2018-1000805  (opens in a new tab)
CWE-732  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 paramiko to version 2.0.0-1ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream paramiko package and not the paramiko package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Paramiko version 2.4.1, 2.3.2, 2.2.3, 2.1.5, 2.0.8, 1.18.5, 1.17.6 contains a Incorrect Access Control vulnerability in SSH server that can result in RCE. This attack appear to be exploitable via network connectivity.

CVSS Base Scores

version 3.1