Out-of-bounds Read Affecting pcre2 package, versions *


low

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Availability High

    Threat Intelligence

    EPSS 0.25% (64th percentile)
Expand this section
NVD
9.1 critical
Expand this section
Red Hat
7.5 high
Expand this section
SUSE
8.6 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-UBUNTU1804-PCRE2-2810788
  • published 7 May 2022
  • disclosed 16 May 2022

How to fix?

There is no fixed version for Ubuntu:18.04 pcre2.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcre2 package and not the pcre2 package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

An out-of-bounds read vulnerability was discovered in the PCRE2 library in the get_recurse_data_length() function of the pcre2_jit_compile.c file. This issue affects recursions in JIT-compiled regular expressions caused by duplicate data transfers.