Files or Directories Accessible to External Parties Affecting phantomjs package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.42% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-PHANTOMJS-543084
  • published10 Nov 2019
  • disclosed5 Nov 2019

Introduced: 5 Nov 2019

CVE-2019-17221  (opens in a new tab)
CWE-552  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:18.04 phantomjs.

NVD Description

Note: Versions mentioned in the description apply only to the upstream phantomjs package and not the phantomjs package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

PhantomJS through 2.1.1 has an arbitrary file read vulnerability, as demonstrated by an XMLHttpRequest for a file:// URI. The vulnerability exists in the page.open() function of the webpage module, which loads a specified URL and calls a given callback. An attacker can supply a specially crafted HTML file, as user input, that allows reading arbitrary files on the filesystem. For example, if page.render() is the function callback, this generates a PDF or an image of the targeted file. NOTE: this product is no longer developed.

CVSS Base Scores

version 3.1