Not Failing Securely ('Failing Open') Affecting pyopenssl package, versions <17.5.0-1ubuntu1+esm1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.25% (17th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-PYOPENSSL-15699676
  • published28 May 2026
  • disclosed18 Mar 2026

Introduced: 18 Mar 2026

CVE-2026-27448  (opens in a new tab)
CWE-636  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 pyopenssl to version 17.5.0-1ubuntu1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pyopenssl package and not the pyopenssl package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

pyOpenSSL is a Python wrapper around the OpenSSL library. Starting in version 0.14.0 and prior to version 26.0.0, if a user provided callback to set_tlsext_servername_callback raised an unhandled exception, this would result in a connection being accepted. If a user was relying on this callback for any security-sensitive behavior, this could allow bypassing it. Starting in version 26.0.0, unhandled exceptions now result in rejecting the connection.

CVSS Base Scores

version 3.1