Integer Overflow or Wraparound Affecting python3.6 package, versions <3.6.9-1~18.04ubuntu1.10


medium

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 1.04% (84th percentile)
Expand this section
NVD
9.8 critical
Expand this section
SUSE
8.1 high
Expand this section
Red Hat
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-UBUNTU1804-PYTHON36-3336634
  • published 1 Nov 2022
  • disclosed 21 Oct 2022

How to fix?

Upgrade Ubuntu:18.04 python3.6 to version 3.6.9-1~18.04ubuntu1.10 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3.6 package and not the python3.6 package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

The Keccak XKCP SHA-3 reference implementation before fdc6fef has an integer overflow and resultant buffer overflow that allows attackers to execute arbitrary code or eliminate expected cryptographic properties. This occurs in the sponge function interface.