Improper Verification of Cryptographic Signature Affecting python-ecdsa package, versions <0.13-2ubuntu0.18.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.53% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-PYTHONECDSA-473511
  • published12 Oct 2019
  • disclosed2 Jan 2020

Introduced: 12 Oct 2019

CVE-2019-14859  (opens in a new tab)
CWE-347  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 python-ecdsa to version 0.13-2ubuntu0.18.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-ecdsa package and not the python-ecdsa package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

A flaw was found in all python-ecdsa versions before 0.13.3, where it did not correctly verify whether signatures used DER encoding. Without this verification, a malformed signature could be accepted, making the signature malleable. Without proper verification, an attacker could use a malleable signature to create false transactions.

CVSS Base Scores

version 3.1