Use After Free Affecting qpdf package, versions <8.0.2-3ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.54% (43rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-QPDF-5927441
  • published4 Oct 2023
  • disclosed11 Aug 2023

Introduced: 11 Aug 2023

CVE-2021-25786  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 qpdf to version 8.0.2-3ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream qpdf package and not the qpdf package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

An issue was discovered in QPDF version 10.0.4, allows remote attackers to execute arbitrary code via crafted .pdf file to Pl_ASCII85Decoder::write parameter in libqpdf.

CVSS Base Scores

version 3.1