HTTP Request Smuggling Affecting resteasy3.0 package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.51% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-RESTEASY30-261315
  • published13 Sept 2017
  • disclosed13 Sept 2017

Introduced: 13 Sep 2017

CVE-2017-7561  (opens in a new tab)
CWE-444  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:18.04 resteasy3.0.

NVD Description

Note: Versions mentioned in the description apply only to the upstream resteasy3.0 package and not the resteasy3.0 package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Red Hat JBoss EAP version 3.0.7 through before 4.0.0.Beta1 is vulnerable to a server-side cache poisoning or CORS requests in the JAX-RS component resulting in a moderate impact.