Cross-site Scripting (XSS) Affecting ruby-loofah package, versions *


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.92% (59th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-RUBYLOOFAH-264702
  • published2 Dec 2018
  • disclosed30 Oct 2018

Introduced: 30 Oct 2018

CVE-2018-16468  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:18.04 ruby-loofah.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-loofah package and not the ruby-loofah package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

In the Loofah gem for Ruby, through v2.2.2, unsanitized JavaScript may occur in sanitized output when a crafted SVG element is republished.