Use of Uninitialized Resource Affecting sane-backends package, versions <1.0.27-1~experimental3ubuntu2.3


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.2% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-SANEBACKENDS-608118
  • published23 May 2020
  • disclosed24 Jun 2020

Introduced: 23 May 2020

CVE-2020-12864  (opens in a new tab)
CWE-908  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 sane-backends to version 1.0.27-1~experimental3ubuntu2.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sane-backends package and not the sane-backends package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

An out-of-bounds read in SANE Backends before 1.0.30 may allow a malicious device connected to the same local network as the victim to read important information, such as the ASLR offsets of the program, aka GHSL-2020-081.

CVSS Base Scores

version 3.1