Improper Data Handling Affecting shutter package, versions <0.94-1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
6.67% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-SHUTTER-277091
  • published29 Dec 2016
  • disclosed29 Dec 2016

Introduced: 29 Dec 2016

CVE-2016-10081  (opens in a new tab)
CWE-19  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 shutter to version 0.94-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream shutter package and not the shutter package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

/usr/bin/shutter in Shutter through 0.93.1 allows user-assisted remote attackers to execute arbitrary commands via a crafted image name that is mishandled during a "Run a plugin" action.