Information Exposure Affecting singularity-container package, versions <2.4.2-4ubuntu0.1~esm1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.47% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-SINGULARITYCONTAINER-451316
  • published11 Jul 2018
  • disclosed5 Jul 2018

Introduced: 5 Jul 2018

CVE-2018-12021  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 singularity-container to version 2.4.2-4ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream singularity-container package and not the singularity-container package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Singularity 2.3.0 through 2.5.1 is affected by an incorrect access control on systems supporting overlay file system. When using the overlay option, a malicious user may access sensitive information by exploiting a few specific Singularity features.