Improper Input Validation Affecting singularity-container package, versions <2.4.2-4ubuntu0.1~esm1


Severity

Recommended
0.0
high
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.47% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-SINGULARITYCONTAINER-451318
  • published13 Dec 2018
  • disclosed17 Dec 2018

Introduced: 13 Dec 2018

CVE-2018-19295  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 singularity-container to version 2.4.2-4ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream singularity-container package and not the singularity-container package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Sylabs Singularity 2.4 to 2.6 allows local users to conduct Improper Input Validation attacks.