Insecure Storage of Sensitive Information Affecting slurm-llnl package, versions <17.11.2-1ubuntu0.1~esm4


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.83% (55th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-SLURMLLNL-1134004
  • published31 Mar 2022
  • disclosed27 Nov 2020

Introduced: 27 Nov 2020

CVE-2020-27746  (opens in a new tab)
CWE-922  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 slurm-llnl to version 17.11.2-1ubuntu0.1~esm4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-llnl package and not the slurm-llnl package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Slurm before 19.05.8 and 20.x before 20.02.6 exposes Sensitive Information to an Unauthorized Actor because xauth for X11 magic cookies is affected by a race condition in a read operation on the /proc filesystem.

CVSS Base Scores

version 3.1