Improper Privilege Management Affecting slurm-llnl package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.3% (67th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-SLURMLLNL-1165964
  • published10 Sept 2020
  • disclosed13 Jan 2020

Introduced: 13 Jan 2020

CVE-2019-19728  (opens in a new tab)
CWE-269  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:18.04 slurm-llnl.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-llnl package and not the slurm-llnl package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

SchedMD Slurm before 18.08.9 and 19.x before 19.05.5 executes srun --uid with incorrect privileges.

CVSS Base Scores

version 3.1