Race Condition Affecting slurm-llnl package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.19% (9th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-SLURMLLNL-6022813
  • published19 Sept 2025
  • disclosed3 Nov 2023

Introduced: 3 Nov 2023

CVE-2023-41914  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:18.04 slurm-llnl.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-llnl package and not the slurm-llnl package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

SchedMD Slurm 23.02.x before 23.02.6 and 22.05.x before 22.05.10 allows filesystem race conditions for gaining ownership of a file, overwriting a file, or deleting files.

CVSS Base Scores

version 3.1