Arbitrary Code Injection Affecting smarty3 package, versions <3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
82.32% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-SMARTY3-1123374
  • published14 Feb 2022
  • disclosed22 Feb 2021

Introduced: 22 Feb 2021

CVE-2021-26120  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 smarty3 to version 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream smarty3 package and not the smarty3 package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Smarty before 3.1.39 allows code injection via an unexpected function name after a {function name= substring.

CVSS Base Scores

version 3.1