Directory Traversal Affecting smarty3 package, versions <3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.66% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-SMARTY3-537854
  • published25 Sept 2018
  • disclosed11 Sept 2018

Introduced: 11 Sep 2018

CVE-2018-16831  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 smarty3 to version 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream smarty3 package and not the smarty3 package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Smarty before 3.1.33-dev-4 allows attackers to bypass the trusted_dir protection mechanism via a file:./../ substring in an include statement.