Uncontrolled Search Path Element Affecting snapcraft package, versions <2.43.1+18.04.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.7% (51st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-SNAPCRAFT-1048214
  • published4 Dec 2020
  • disclosed4 Dec 2020

Introduced: 4 Dec 2020

CVE-2020-27348  (opens in a new tab)
CWE-427  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 snapcraft to version 2.43.1+18.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream snapcraft package and not the snapcraft package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

In some conditions, a snap package built by snapcraft includes the current directory in LD_LIBRARY_PATH, allowing a malicious snap to gain code execution within the context of another snap if both plug the home interface or similar. This issue affects snapcraft versions prior to 4.4.4, prior to 2.43.1+16.04.1, and prior to 2.43.1+18.04.1.

CVSS Base Scores

version 3.1