SQL Injection Affecting sogo package, versions <3.2.10-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.24% (15th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-SOGO-16781060
  • published30 Jun 2026
  • disclosed14 May 2026

Introduced: 14 May 2026

CVE-2026-46446  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 sogo to version 3.2.10-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sogo package and not the sogo package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

SOGo before 5.12.7, when PostgreSQL or MariaDB is used, and cleartext passwords are stored, allows SQL injection. This is related to c_password = '%@' in changePasswordForLogin.